Atari MuseumAtari ST ProjekteProjekteRetro Museum

Mein “erster” Atari ST

Atari 1040STFM #1 Label

Nun, neu ist er sicher nicht - und mein erster ist er auch nicht.

Aber aus heutiger, Retro-Sammler-Sicht, ist es mein „erster“. Und da mein letzter vor über 20 Jahren verkauft wurde, ist dieser auch mein „neuer“. Ersteigert für ca EUR 20,- bei eBay - komplett mit Maus und Monochrom-Monitor SM124 - ein Schnäppchen!

Atari 1040STFM #1
Atari 1040STFM #1 SM124

Technische Daten

TypSTFM
RAM1MB (2 Bänke a 512 kB)
BoardC070789-001 Rev D
Serien-NummerA102L4043932
FloppyEpson SMD-380 (DD)
TOS1.02 (original), 1.04 (aufgerüstet, 6 Chips)
ZustandGanz wenig Gilb; kleines Gehäuseteil hinten rechts ausgebrochen, aber noch vorhanden (fast unsichtbar wieder eingeklebt)
BesonderheitenTOS in 1M Chips (2 Stk), restl. 4 Plätze ohne Sockel

Restauration

Als Erstes wurde das Gerät komplett zerlegt und gereinigt. Alle Plastikteile werden dazu in warmen Wasser mit ein wenig Spüli eingeweicht und mit einer nicht zu harten Bürste abgeschrubbt. Beim Label auf der Unterseite muss man etwas aufpassen - nicht zu lange einweichen und nicht zu doll abbürsten. 

Theoretisch kann man auch das Mainboard in Wasser säubern - einige schwören sogar darauf, Mainboards im Geschirrspüler zu reinigen. Gründliche Trocknung danach ist dann natürlich nötig. Ich würde das nur in Ausnahmefällen tun (extreme Verschmutzung) - mit einem festen Pinsel abstauben oder ggf. mit etwas Isopropylalkohol behandeln sollte in den meisten Fällen reichen.

Bei der Säuberungsaktion dieses Rechners stellte ich einen kleinen Defekt am Gehäuse fest (kleines Plastikteil war herausgebrochen). Wahrscheinlich beim Transport, denn das Plastikteil war noch vorhanden. Ließ sich mit Sekundenkleber fast unsichtbar wieder einsetzen.

Wie im letzten Artikel beschrieben, war in Sachen Elektronik-Reparatur als Erstes das Netzteil dran. Hierzu wurden sämtliche Elkos ausgetauscht. Den Brücken-Gleichrichter habe ich erstmal drin gelassen - manchmal ist auch der fällig.

Bevor weitere Umbauten erfolgen sollten, gab es erstmal einen Funktionstest.

Strom an, einschalten, und er bootete. Ohne Startdiskette im Laufwerk dauert das ganze ein wenig - also nicht ungeduldig werden.

Es begrüßte mich der bekannte (und vermisste) GEM-Desktop. Schnell im Info-Dialog nachgeschaut: TOS 1.02 - also eine der ersten Versionen. Damit war klar, dass die erste Erweiterung ein TOS 1.04 sein würde.

Da das aktuelle TOS 1.02 als 2-Chip-Version eingebaut war (1Mbit-Chips), sich TOS 1.04 bei eBay aber nur als 6-Chip Version (256kBit) auftreiben liess, konnte ich die beiden ROMs leider nicht einfach durch zwei EPROMS mit TOS 1.04 ersetzen. Es mussten also die 4 freien ROM-Plätze mit 28-poligen Sockeln bestückt werden. Weiterhin gibt es auf dem Board noch drei Lötpads, jeweils mit 256k bzw 1M beschriftet, die entsprechend umgelötet werden müssen.

Da der Rechner schonmal zerlegt war, kam noch eine etwas knifflige Aufgabe hinzu: Sockeln des 68000 Prozessors. Viele Erweiterungen kommen auf (bzw. unter) den Prozessor. Da ist ein gesockelter Chip ganz praktisch.

Das Auslöten eines Chips mit 40 Pins ist nicht ganz trivial: viel Flussmittel und neues Lötzinn erleichtern das Auslöten (klingt komisch, ist aber wahr). Eine gute Entlötpumpe - in meinem Fall eine Lötstation mit elektrischer Entlötpumpe - erhöht die Erfolgschancen. Hier hat alles geklappt: Prozessor erfolgreich ausgelötet, Board und Chip heil geblieben, Sockel rein, Prozessor wieder drauf - läuft.

Als nächstes ist noch eine Speichererweiterung auf 4MB geplant - da muss ich aber erstmal recherchieren, welche es denn sein wird (gibt mehrere Varianten).

Aber das kommt in einer anderen Story

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.